Welcome, Guest
Username: Password: Remember me
here you can submit any topics related ExtraWatch

TOPIC: Want to upgrade, can't uninstall old version

Want to upgrade, can't uninstall old version 1 year 2 days ago #929

Installed:
ExtraWatch 2.3.2616
Joomla 3.6.4
PHP 7.0.8-0ubuntu0.16.04.3

ExtraWatch won't work in this configuration (in fact, it disables my whole web site!), so I have disabled ExtraWatch.

I would like to upgrade ExtraWatch, and I have downloaded a new version.

I did not find explicit instructions on how to upgrade. The nearest I found was this:
www.extrawatch.com/component/rsticketspr...without-loosing-data
However, when I try to uninstall the ExtraWatch extension using the joomla extension manager, I receive the following error message:
Fatal error: Redefinition of parameter $recipient in /var/www/html/joomla/components/com_extrawatch/src/env/interface.extrawatch.env.php on line 49

Could you please help me to get ExtraWatch updated and functional again on my system!
The administrator has disabled public write access.

Want to upgrade, can't uninstall old version 1 year 2 days ago #930

Hi,
looks like you're running a version of ExtraWatch which does not support PHP 7.
Please get the latest version from the customer zone.

In order to make your website functioning again, make sure that ExtraWatch agent module is not published.

You can disable the agent module directly in the database (find it using the PhpMyAdmin, in the DB table #__extensions)
The administrator has disabled public write access.

Want to upgrade, can't uninstall old version 1 year 1 day ago #931

The ExtraWatch agent module is disabled.

When I attempt to uninstall the old ExtraWatch, I receive the following error message:

Fatal error: Redefinition of parameter $recipient in /var/www/html/joomla/components/com_extrawatch/src/env/interface.extrawatch.env.php on line 49

Where do you publish what version of PHP is required by each version of ExtraWatch?

Could you please help me to get the old version of ExtraWatch uninstalled?
The administrator has disabled public write access.

Want to upgrade, can't uninstall old version 1 year 9 hours ago #932

Hi,
1. Try to switch back to PHP version 5,
2. uninstall ExtraWatch
3. switch back PHP 7
4. install latest version of ExtraWatch from the customer download zone
The administrator has disabled public write access.

Want to upgrade, can't uninstall old version 11 months 1 week ago #937

After some significant effort, I have managed to follow your advice and I did mange to un-install the old version of ExtraWatch and then install the new version.
I found that there is a way of installing php5.6 and php7.0 simultaneously on Ubuntu 16.04:
lornajane.net/posts/2016/php-7-0-and-5-6-on-ubuntu
Be careful to install all the necessary packages to support Joomla using your chosen version of PHP, refer
idroot.net/linux/install-joomla-ubuntu-16-04/
So the suggested method is possible, but its not easy.
The administrator has disabled public write access.
Time to create page: 0.176 seconds

ExtraWatch is proudly featured at:

This widget is powered by website.informer.com

X

Drop us your message